最新消息:

解决wordpress更新时出现“要执行请求的操作,WordPress需要访问您网页服务器的权限”的问题”

技术笔记 shanyubawo 904浏览 0评论

安装一个demo站点时,使用的是ssh后台下载wordpress解压缩。站点建立完成之后,看到有更新,就选择了更新,但是却出现“要执行请求的操作,WordPress需要访问您网页服务器的权限”,这个问题之前也碰到过,但是忘记怎么解决。上网搜索了下,有两种常用的方法。

方法一:修改wp-config.php文件

 

define("FS_METHOD", "direct");
define("FS_CHMOD_DIR", 0777);
define("FS_CHMOD_FILE", 0777);


 

将这三行加在wp-config.php文件的最后。PS:这个方法我没有使用。

 

方法二:修改wordpress文件夹目录权限

 

chown -R www  www/wwwroot/demo.hostodo.myownhost.cn

 

这种方法就是将文件夹的权限修改为www用户,因为使用ssh下载和解压缩时默认是root用户。

 

方法网上很明确,记录下。

转载请注明:春风博客 » 解决wordpress更新时出现“要执行请求的操作,WordPress需要访问您网页服务器的权限”的问题”

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址